Why does x-lite not work behind some routers?

Why does x-lite not work behind some routers?

Postby pointer4 » Thu Nov 20, 2008 2:28 pm

I have installed x-lite at some employees homes and found that X-lite connect connect to our hosted pbx system with certain routers, while others work fine. Why is this? For instance yesterday I setup x-lite on my Linksys WRT54G router and it worked perfectly well. I then went to another employees home and installed it behind their Belkin router. I don't get it.
pointer4
 
Posts: 2
Joined: Thu Nov 20, 2008 1:08 pm

Re: Why does x-lite not work behind some routers?

Postby andy gold » Thu Nov 20, 2008 2:32 pm

This happens because some routers (Belkin is a real problem when it comes to all VoIP equipment) do not support the SIP protocol properly and thus do not pass SIP signals properly through the router to the your hosted pbx provider and thus x-lite cannot connect or you experience other odd issues (like the phone not ringing when it should). There are quite a few routers that I personally know do this like 2wire, belkin and netopia, they are all terrible routers when it comes to voip. Whats the solution? Get a router that's voip compadible. I personally like Linksys routers and haven't had issues with any of them. Sometimes you will also end up with a situation where you have a router plugged into what you think is just a simple modem. But often in the past few years modems have built in routers so you have two DHCP servers and the router is actually connected to another router/modem and you end up with double NAT issues. The solution to that is to make sure your modem is acting just as a bridge and not a router (you ISP can tell you have to bridge it).
andy gold
 
Posts: 19
Joined: Thu Nov 20, 2008 1:07 pm


Return to X-Lite Soft Phone Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests